How to Solve OBD2 Port Not Communicating with Tech 2 Scanner

car diagnostic tool

This post collected the problem “OBD2 Port Not Communicating with Vetronix Tech 2 Scanner” from the user and offered the way to deal with. Hope it may help you when you meet the same 

I recently purchased a clone GM Tech2 scanner to access the diagnostics in my 2006 Hummer H2. The scanner is operational and can scan all protocols but can not link to any of them. There are no driveability issues. I performed troubleshooting by doing the following:

  1. Verified that the Power Control Module (PCM) and Data Link Connector (DLC) fuses were okay.
  2. Tested DLC pins 4 (chassis ground) and 5 (PCM ground). The voltage was less than 0.1 which led me to believe low resistance.
  3. Performed a volt reference check on DLC pin 2 (serial data) to determine if it was 5 volts and actual voltage was between 1 and 2.
  4. Tested DLC pins 4 and 16 (battery) and the voltage was 12.58.
  5. Checked the purple, black, black/white and orange wires on the back of the DLC for integrity and did not find any issues with fraying or looseness.

I am not sure what to think, whether the issue is with the PCM or wiring. I am trying to locate a wiring diagram for the PCM and DLC which will give me a better understanding of the wire mapping. I know the PCM has two connectors and I probably should see if there is continuity in the purple wire (Pin 2) and its termination in one or the other connector.

Solution:

“DLC” is the Datalink connector (the connector that pushes into the vehicle) so “DLC-2” is Data Link Connector pin 2.
“D” is the 26-Way D-Type Connector that screws into your Tech2, “D-4” is 26-Way D-Type pin 4.
So if you look at the ends of the cable connectors, the pins are numbered as per my sketch.

So detach your TECH2’s cable and check the following:

  1. DLC-2 connects to D-4
  2. DLC-4 connects to both D-8 and D-9
  3. DLC-5 connects to D-2
  4. DLC-16 connects to both D-17 and D-18

These 4 wires are the only important ones, the rest you can ignore, infact DLC-2 to D-4 is the key one, I suspect everything else is OK.

Your TECH2 should have come with a 12V Power Supply that plugs-in just to the right of the 26-Way D-Type, its a standard 12V jack. If you don’t have a PSU one from a PC monitor, just check its 12V.

Connect scope probe tip to DLC-2 and ground clip to either DLC-4 or DLC-5, set the scope to DC, 1V/Division and 200uS/Division. If you can set the scope to “free run” or “continuous” just to prove there is activity then set it to “DC Triggered” with a trigger level of around +1V to +2V. On the TECH2 select the function I mentioned before (even if your vehicle doesn’t have AS) and you should see a signal the moment you hit the key.

If the signal looks similar to the one I posted, then its safe to assume your TECH2 is working OK.

When you say “The scanner is operational and can scan all protocols but cannot link to any of them” do you get a communications error? If so make sure you have selected the correct “Model Year” not the year the truck was 1st bought e.g. my model year is 2005 but was bought in 2006. I noticed that I get the same issue when the wrong year is selected.