Why I should update xentry to new version?

Chinacardiag QuestionsWhy I should update xentry to new version?
sales Staff asked 3 months ago

Why I should update xentry to new version? 
for my mb sd c4 and mb sd c5

2 Answers
sales Staff answered 3 months ago

New version xentry Generally support updated new models. And online programming requires the latest version.

sales Staff answered 3 months ago

New version xentry Generally support updated new models. And online programming requires the latest version.